Office: 503-443-2000 | Fax: 503-968-1877 | Email:
Nu Tech Software Solutions is an Information Technology Services and Software Development company.
We focus on highly available applications for both the Internet and Enterprise. Expertise in both the Microsoft and Linux/LAMP environments.
If you need a Content Management System (CMS) we can do it! We are experienced with both Joomla! and Drupal!
Contact us at: Phone: (503) 443-2000, Email:

Home
AlarmDecoder/AD2USB
Contact Us
AlarmDecoder Forum
FAQ
Online Store
 
Welcome, Guest
Please Login or Register.    Lost Password?
Relay support (initial beta report) (1 viewing) (1) Guest
Discuss our ADEMCO Emulator hardware.
Go to bottom Favoured: 0
TOPIC: Relay support (initial beta report)
#1769
Re:Relay support (initial beta report) 4 Years, 1 Month ago Karma: 0  
mathewss wrote:
Can you post the exact message from the panel. The one you are showing is missing parts so I can understand why it parsed badly. I know I recently did a firmware patch to allow relay emulation to work on SE panels.

At some point I plan on pushing the GUI to github. I just need some time to clean stuff up before I dump it to the world. This year we moved everything to git so that was part of the battle.



Sean,

the message is

!REL:01,01,01

This is from the telnet session to the server running in ad2usbgui

If you do make more of the source available, I would like to make this a gui-less service on Windows, if possible. I'd like to have the facility that goes beyond ser2sock running at all times, for maintaining state and being able for other apps to "see" what any sensor is doing based on its last check-in state. My system is wireless, but each wireless door sensor has a second wired loop that can be utilized. In my case, I can use both in some instances, but only actively monitor the first one. The second could be "information-only" for some yet to be defined purpose, or as a "follower" zone.
DKane (User)
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
The administrator has disabled public write access.  
#1770
Re:Relay support (initial beta report) 4 Years, 1 Month ago Karma: 1  
Yeah, if you're not using the hard-wired inputs, I can't see any reason to use the virtual relay support.

I use the MiCasaVerde Vera automation controller. What I like about it is that it's free of monthly fees, and open for developers to author drivers. Users have written drivers for all sorts of things. As long as the device is serial or ethernet, you can easily write LUA code to control it. I planned to do an AD2USB driver, but MCV started writing their own interface for it as soon as they were aware of it.

It's also very easy to control and get status from Vera through HTTP get requests. If you'd rather treat Vera like a "dumb" controller you can do that too.
djrobx (User)
Fresh Boarder
Posts: 17
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
The administrator has disabled public write access.  
#1771
Re:Relay support (initial beta report) 4 Years, 1 Month ago Karma: 7  
Looks like 2 places this bug exists. In relay and expander messages parsing. I copied / pasted my code from RFX message section and the format of the message is a lot different.

The failure happens in trying to find this item in the config file. If it finds it then no error will happen. The error happens when it does not find it and then attempts to append to the "ITEMS" view with no config.


Try adding a relay element for your sensor in your config.

<Sensor Id="401" Type="RELAY" Name="01" Template="4204" Layout="binary" Coords="400,460,4" />

This presumes you have the latest GUI with relay templates etc supported.

I will try and get this bug fixed asap but I am in the middle of a commit to allow support for SSL connections to the new ssl enabled ser2sock.

Re
Sean M
mathewss (Admin)
Admin
Posts: 512
graph
User Offline Click here to see the profile of this user
Gender: Male
Logged Logged  
 
struct SoftwareProfessional {
double salary;
long lunches;
float jobs;
char unstable;
void work;
short tempers;
};
 
The administrator has disabled public write access.  
#1772
Re:Relay support (initial beta report) 4 Years, 1 Month ago Karma: 0  
mathewss wrote:
...

The failure happens in trying to find this item in the config file. If it finds it then no error will happen. The error happens when it does not find it and then attempts to append to the "ITEMS" view with no config.


Try adding a relay element for your sensor in your config.

<Sensor Id="401" Type="RELAY" Name="01" Template="4204" Layout="binary" Coords="400,460,4" />


Ah, I tried all sorts of IDs (01, 001, 101) before I posted, but not "401". That works.

Are the positions in the config and bits reversed? I've not tried programming the 02 relay, but Relay 401 Bit 01 appears in Position 4.
DKane (User)
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
The administrator has disabled public write access.  
#1773
Re:Relay support (initial beta report) 4 Years, 1 Month ago Karma: 7  
Ya I can see how this seems reversed. Its just how my brain works

Its binary so 0001 would be relay 1 on. 0101 would be relay 3 and 1.


Re
Sean M
mathewss (Admin)
Admin
Posts: 512
graph
User Offline Click here to see the profile of this user
Gender: Male
Logged Logged  
 
struct SoftwareProfessional {
double salary;
long lunches;
float jobs;
char unstable;
void work;
short tempers;
};
 
The administrator has disabled public write access.  
#1774
Re:Relay support (initial beta report) 4 Years, 1 Month ago Karma: 0  
Big Endian, Little Endian - we're all friends here!

Well, I'm back on track, thanks for your help.
DKane (User)
Fresh Boarder
Posts: 5
graphgraph
User Offline Click here to see the profile of this user
Logged Logged  
 
The administrator has disabled public write access.  
Go to top





Lost Password?
©2017 Nu Tech Software Solutions, Inc. | Terms and Conditions | Service Level Agreement | Acceptable Use Policies | Contact Us